Author Topic: Some of the software failed with Debian 9  (Read 169 times)

Loren Tedford

  • Newbie
  • *
  • Posts: 37
  • I love Amateur Radio, VPS and Minecraft!
    • View Profile
    • Welcome to Lorentedford.com
Some of the software failed with Debian 9
« on: May 08, 2018, 12:31:59 pm »
Here is my logs

I did install this to help get some of the packages but what other packages am i missing?

Code: [Select]
apt-get install software-properties-common
Code: [Select]
root@theworldhub:~# sudo bash "ehcpforceupdate.sh" "update"
Running EHCP Force Edition update script...
Retrieving Distribution Information
Your distro is debian runnning version 9.4
Stopping services
stoping specifically detected php-fpm service php7.0-fpm...
Installing any missing software packages that are needed by the latest version of EHCP Force!
Reading package lists... Done
Building dependency tree
Reading state information... Done
lsb-release is already the newest version (9.20161125).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Reading package lists... Done
Building dependency tree
Reading state information... Done
gdebi-core is already the newest version (0.9.5.7+nmu1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Reading package lists... Done
Building dependency tree
Reading state information... Done
ftp is already the newest version (0.17-34).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Reading package lists... Done
Building dependency tree
Reading state information... Done
sshpass is already the newest version (1.06-1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Reading package lists... Done
Building dependency tree
Reading state information... Done
apache2-utils is already the newest version (2.4.25-3+deb9u4).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package python-software-properties is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  software-properties-common

E: Package 'python-software-properties' has no installation candidate
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package python-software-properties is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  software-properties-common

E: Package 'python-software-properties' has no installation candidate
Reading package lists... Done
Building dependency tree
Reading state information... Done
debconf-utils is already the newest version (1.5.61).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package php-mail-mimedecode
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package php-mail-mimedecode
Reading package lists... Done
Building dependency tree
Reading state information... Done
php7.0-zip is already the newest version (7.0.27-0+deb9u1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package php5-gd is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'php5-gd' has no installation candidate
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package php5-gd is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'php5-gd' has no installation candidate
Reading package lists... Done
Building dependency tree
Reading state information... Done
php7.0-gd is already the newest version (7.0.27-0+deb9u1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package php5-zip
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package php5-zip
Reading package lists... Done
Building dependency tree
Reading state information... Done
python is already the newest version (2.7.13-2).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Reading package lists... Done
Building dependency tree
Reading state information... Done
libexpat1-dev is already the newest version (2.2.0-2+deb9u1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Reading package lists... Done
Building dependency tree
Reading state information... Done
libpython-dev is already the newest version (2.7.13-2).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Reading package lists... Done
Building dependency tree
Reading state information... Done
libpython2.7-dev is already the newest version (2.7.13-2+deb9u2).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Reading package lists... Done
Building dependency tree
Reading state information... Done
python-setuptools is already the newest version (33.1.1-1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Reading package lists... Done
Building dependency tree
Reading state information... Done
python2.7-dev is already the newest version (2.7.13-2+deb9u2).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Reading package lists... Done
Building dependency tree
Reading state information... Done
libssl-doc is already the newest version (1.1.0f-3+deb9u2).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Reading package lists... Done
Building dependency tree
Reading state information... Done
openssl is already the newest version (1.1.0f-3+deb9u2).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Reading package lists... Done
Building dependency tree
Reading state information... Done
python-pip is already the newest version (9.0.1-2).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Reading package lists... Done
Building dependency tree
Reading state information... Done
augeas-tools is already the newest version (1.8.0-1+deb9u1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Reading package lists... Done
Building dependency tree
Reading state information... Done
libffi-dev is already the newest version (3.2.1-6).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Reading package lists... Done
Building dependency tree
Reading state information... Done
libssl-dev is already the newest version (1.1.0f-3+deb9u2).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Reading package lists... Done
Building dependency tree
Reading state information... Done
python-dev is already the newest version (2.7.13-2).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Reading package lists... Done
Building dependency tree
Reading state information... Done
python-virtualenv is already the newest version (15.1.0+ds-1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Downloading and installing package updates!

apt-get seems to be installed on your system.

Updating package information and downloading package updates before installation.
Warning: 'apt-key update' is deprecated and should not be used anymore!
Note: In your distribution this command is a no-op and can therefore be removed safely.
Ign:1 http://mirrors.linode.com/debian stretch InRelease
Get:2 http://mirrors.linode.com/debian-security stretch/updates InRelease [94.3 kB]
Get:3 http://mirrors.linode.com/debian stretch-updates InRelease [91.0 kB]
Hit:4 http://mirrors.linode.com/debian stretch Release
Get:5 http://mirrors.linode.com/debian-security stretch/updates/main Sources [136 kB]
Get:6 http://mirrors.linode.com/debian-security stretch/updates/main amd64 Packages [374 kB]
Get:7 http://dvswitch.org/ASL_Repository stretch InRelease [4,806 B]
Get:8 http://mirrors.linode.com/debian stretch-updates/main Sources.diff/Index [4,180 B]
Get:9 http://mirrors.linode.com/debian stretch-updates/main amd64 Packages.diff/Index [4,180 B]
Get:10 http://mirrors.linode.com/debian stretch-updates/main Sources 2018-05-05-2031.58.pdiff [552 B]
Get:11 http://mirrors.linode.com/debian stretch-updates/main amd64 Packages 2018-05-05-2031.58.pdiff [329 B]
Get:10 http://mirrors.linode.com/debian stretch-updates/main Sources 2018-05-05-2031.58.pdiff [552 B]
Get:11 http://mirrors.linode.com/debian stretch-updates/main amd64 Packages 2018-05-05-2031.58.pdiff [329 B]
Get:13 http://dvswitch.org/ASL_Repository stretch/hamradio amd64 Packages [4,981 B]
Fetched 714 kB in 0s (1,062 kB/s)
Reading package lists... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages will be upgraded:
  tzdata wget
2 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 1,067 kB of archives.
After this operation, 0 B of additional disk space will be used.
Get:1 http://mirrors.linode.com/debian stretch-updates/main amd64 tzdata all 2018e-0+deb9u1 [267 kB]
Get:2 http://mirrors.linode.com/debian-security stretch/updates/main amd64 wget amd64 1.18-5+deb9u2 [799 kB]
Fetched 1,067 kB in 0s (22.2 MB/s)
apt-listchanges: Reading changelogs...
Preconfiguring packages ...
(Reading database ... 79767 files and directories currently installed.)
Preparing to unpack .../tzdata_2018e-0+deb9u1_all.deb ...
Unpacking tzdata (2018e-0+deb9u1) over (2018d-0+deb9u1) ...
Preparing to unpack .../wget_1.18-5+deb9u2_amd64.deb ...
Unpacking wget (1.18-5+deb9u2) over (1.18-5+deb9u1) ...
Setting up tzdata (2018e-0+deb9u1) ...

Current default time zone: 'Etc/UTC'
Local time is now:      Tue May  8 18:16:38 UTC 2018.
Universal Time is now:  Tue May  8 18:16:38 UTC 2018.
Run 'dpkg-reconfigure tzdata' if you wish to change it.

Setting up wget (1.18-5+deb9u2) ...
Processing triggers for man-db (2.7.6.1-2) ...
Making Sure nginx and php-fpm Are Installed

Reading package lists... Done
Building dependency tree
Reading state information... Done
nginx is already the newest version (1.10.3-1+deb9u1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package php5-fpm
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package php5-fpm
Reading package lists... Done
Building dependency tree
Reading state information... Done
php-fpm is already the newest version (1:7.0+49).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Checking to make sure nginx is disabled!

update-rc.d: error: no runlevel symlinks to modify, aborting!
Checking Apache2 EnvVars for Errors

Fixing php-fpm Listen Settings

restarting specifically detected php-fpm service php7.0-fpm...

Changing Apache User

Adding rate limiting for nginx

Enabling Slave DNS


Changing bind apparmor rule to allow master DNS synchronization for slave setups.

Failed to restart apparmor.service: Unit apparmor.service not found.
Setting roundcube as default email client for websites.

Retrieving Latest EHCP Force Files and Making a Backup of Original Files

Running MySQL Bind Address Fix

Updating Base nginx Configuration Files

Checking for VSFTPD Updates

Reading package lists... Done
Building dependency tree
Reading state information... Done
vsftpd is already the newest version (3.0.3-8+b1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be REMOVED:
  libpam-ldap
0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
After this operation, 250 kB disk space will be freed.
(Reading database ... 79756 files and directories currently installed.)
Removing libpam-ldap:amd64 (186-4) ...
Processing triggers for man-db (2.7.6.1-2) ...
Reading package lists... Done
Building dependency tree
Reading state information... Done
Suggested packages:
  libnss-ldapd | libnss-ldap
The following NEW packages will be installed:
  libpam-ldap
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/87.0 kB of archives.
After this operation, 250 kB of additional disk space will be used.
Preconfiguring packages ...
Selecting previously unselected package libpam-ldap:amd64.
(Reading database ... 79720 files and directories currently installed.)
Preparing to unpack .../libpam-ldap_186-4_amd64.deb ...
Unpacking libpam-ldap:amd64 (186-4) ...
Processing triggers for man-db (2.7.6.1-2) ...
Setting up libpam-ldap:amd64 (186-4) ...
mkdir: cannot create directory ‘lib32gccfix’: File exists
ldap.conf
Reading package lists... Done
Building dependency tree
Reading state information... Done
libgcc1 is already the newest version (1:6.3.0-18+deb9u1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Checking for Generic Fixes Depending on Ubuntu Version

Reading package lists... Done
Building dependency tree
Reading state information... Done
build-essential is already the newest version (12.3).
libpam-python is already the newest version (1.0.6-1).
python-dev is already the newest version (2.7.13-2).
python-pip is already the newest version (9.0.1-2).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Requirement already satisfied: passlib in /usr/local/lib/python2.7/dist-packages
'/var/www/new/ehcp/etc/pam/pam_dbauth_smtp.conf' -> '/etc/security/pam_dbauth_smtp.conf'
'/var/www/new/ehcp/etc/pam/pam_dbauth_smtp.py' -> '/etc/security/pam_dbauth_smtp.py'
'/var/www/new/ehcp/etc/pam/pam_dbauth_vsftpd.conf' -> '/etc/security/pam_dbauth_vsftpd.conf'
'/var/www/new/ehcp/etc/pam/pam_dbauth_vsftpd.py' -> '/etc/security/pam_dbauth_vsftpd.py'
Upgrading courier authmysqlrc format if needed...

Running generic fixes...

Making Apache more secure by not listing files within a folder without an index page.

Reading package lists... Done
Building dependency tree
Reading state information... Done
Package php5-mcrypt is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'php5-mcrypt' has no installation candidate
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package php5-mcrypt is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'php5-mcrypt' has no installation candidate
Reading package lists... Done
Building dependency tree
Reading state information... Done
php-mcrypt is already the newest version (1:7.0+49).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
ehcpforceupdate.sh: line 1711: php5enmod: command not found
Fixing apache2 umask issue if applicable!

Securing PHPMyAdmin Configuration!

Reading package lists... Done
Building dependency tree
Reading state information... Done
php-gettext is already the newest version (1.0.12-0.1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Disabling BIND Recursion

Fixing SASLAuth caching and setting maximum number of threads to 2.

Setting Postfix Configuration to Allow IPv6 Local IP Relay

Making sure pop-before-smtp has been installed and installing it if missing.

Reading package lists... Done
Building dependency tree
Reading state information... Done
pop-before-smtp is already the newest version (1.41-1.1ubuntu1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading state information... Done
(Reading database ... 79767 files and directories currently installed.)
Preparing to unpack pop-before-smtp.deb ...
Unpacking pop-before-smtp (1.41-1.1ubuntu1) over (1.41-1.1ubuntu1) ...
Setting up pop-before-smtp (1.41-1.1ubuntu1) ...
Processing triggers for systemd (232-25+deb9u3) ...
Processing triggers for man-db (2.7.6.1-2) ...
Configuring php.ini settings for optimal usage.

Fixing roundcube configuration so that email file attachments will work.

Setting default roundcube mail server to localhost.

Checking Postfix configuration for problems...

Fixing /etc/bind directory permissions required for slave DNS.
Fixing SquirrelMail configuration to use Sendmail by default.

Presenting Additional User Options

Anti-Spam software has been detected and is already installed.
PolicyD software has been detected and is already installed.

Updating the PolicyD daemon if necessary.
cat: /etc/init.d/policyd_agent: No such file or directory

An older version of PolicyD has been detected on this system... updating the daemon and start script now.

Fail2Ban has been detected and is already installed.
Apache2 security and evasive modules have been detected and are already installed.
Prompting for MySQL to MariaDB Conversion

MariaDB is already installed on the server.
Adding email blacklist lookup for incoming emails.

Restarting web services, synchronizing domains, and finalizing installation!

getwebservertype.php
Session timeout is configured to be to 24 minutes!
Adding cronjob to clear sessions last accessed more than 24 minutes ago.
Removing cronjob /var/www/new/ehcp/scripts/cleanup/remove_old_php_tmp_session_files.sh!
syncdomains.php
update_ez_install.php
ehcpforceupdate.sh: line 1268: kill: (29825) - No such process
Waiting 30 seconds before restarting apache2 daemon so that website configs are reconstructed.
Restarting the apache2 web server.
Adjusing and restarting courier-authdaemon defaults.
Restarting postfix.
Running final cleanup.
Writing out versioning information!
Successfully updated EHCP Force Edition to the latest version of EHCP Force Edition!
root@theworldhub:~#

earnolmartin

  • Administrator
  • Full Member
  • *****
  • Posts: 177
    • View Profile
Re: Some of the software failed with Debian 9
« Reply #1 on: May 12, 2018, 04:10:23 pm »
I'm not seeing anything out of the normal.  Some packages will fail to install depending on the operating system and version, but that's normal and OK because of compatibility reasons with older and newer operating system versions.

Did you install software-properties-common for any particular reason?

earnolmartin

  • Administrator
  • Full Member
  • *****
  • Posts: 177
    • View Profile
Re: Some of the software failed with Debian 9
« Reply #2 on: May 22, 2018, 12:22:09 pm »
I finally got around to additional testing in debian 9.

Ok, I added software-properties-common to the installer and upgrader.  This package is evidently needed to use add-apt-repository commands. 

Thanks for the report.  It should be fixed in the next released version (soon).