Specific OS Issues > Ubuntu

[Samba Bug] stackframe at ../source3/param/loadparm.c:4864, leaking memory


Loren Tedford:
I figured i would post this in Bugs because it could affect users on first time installation of EHCPForce This is what I found and how I solved it in better description..
This error appears after su and apply your correct root password.
no talloc stackframe at ../source3/param/loadparm.c:4864, leaking memory

I solved this error from Ubuntu Forms located here: http://ubuntuforums.org/showthread.php?t=2214042

Here is the article i found useful to my case:
You can also fix this issue while keeping libpam-smbpass installed by running "pam-auth-update" and remove "SMB password synchronization". Got that solution from Thomas (reusch) on https://bugs.launchpad.net/ubuntu/+s...a/+bug/1257186

The Fix

Run the Number one in the command line it will open up a selection box where you can unselect "SMB password synchronization"

* pam-auth-update
* and remove "SMB password synchronization"

As posted in the other thread, this doesn't have anything to do with EHCP Force.  It is a bug with the Samba package which you shouldn't be using on a server anyways.  If the server is compromised, so is everything else that Samba connects up to.  Though this is unlikely, it is something to consider.

Thanks for posting a solution for those who encounter this error; however, it is not EHCP Force related.


[0] Message Index

Go to full version